Incident with cineSync and ShotGrid integration
Incident Report for ftrack
Postmortem

Earlier today we received multiple reports of users unable to authenticate with the ShotGrid integration within cineSync. A recent change in ShotGrid code and infrastructure required a new build of cineSync to be deployed in order for us to accommodate the change.

Our team quickly issued a new beta of cineSync which has addressed the issue. Only users who need to login to Shotgrid via the integration will need to install the beta - guests in a cineSync review will not need the beta unless you have require guests to log in to SG set in the integration preferences.

The beta builds can be accessed here and we will upload them to our main download pages soon

cineSync 4

Mac OS X

Windows

cineSync 5 / Play

Mac OS X

Windows

Windows (No Installer)

There will be a full release in the next couple of weeks, once we’ve done a full QA cycle and included some other scheduled changes.

Our sincere apologies for any disruption caused by this incident. The team is monitoring the situation closely and will continue to update here should anything change. If you're still seeing any issues, or if you have any questions, please don't hesitate to reach out to support@ftrack.com and the team will get you sorted!

Posted May 12, 2022 - 05:45 CEST

Resolved
We've confirmed the new beta release has addressed the issue, and users should now be able to authenticate using the ShotGrid integration again.
Posted May 12, 2022 - 04:01 CEST
Update
We are continuing to monitor for any further issues.
Posted May 12, 2022 - 03:53 CEST
Monitoring
Our engineering team have issued a new beta release to address the problem. Only users who need to login to ShotGrid via the integration will need to install the beta - guests in a cineSync review will not need the beta unless you have "require guests to log in to SG" set in the integration preferences

Download links to the beta versions can be accessed below and we will update our official download pages soon

cineSync 4
* https://www.cinesync.com/files/cineSync_OSX_4.2.7_beta2.dmg
* https://www.cinesync.com/files/cineSync_WIN_4.2.7_beta2.zip

cineSync 5 / Play
* https://www.cinesync.com/files/cineSyncPlay_WinNoInstaller_1.0.1_beta1.1.zip
* https://www.cinesync.com/files/cineSyncPlay_Win_1.0.1_beta1.1.zip
* https://www.cinesync.com/files/cineSyncPlay_macOS_1.0.1_beta1.1.dmg

We will continue to monitor the situation and will provide a final update here soon
Posted May 12, 2022 - 03:50 CEST
Update
It has been confirmed that a recent change in ShotGrid code and infrastructure will require a change to both cineSync 4 and 5 to ensure a functional ShotGrid integration. We are working to get bugfixed versions of cineSync out as soon as possible but in the meantime for any immediate reviews, we suggest sending media through an alternate transfer method (FTP, Aspera etc) so that cineSync reviews can happen.
Posted May 12, 2022 - 00:08 CEST
Update
We are continuing to investigate the situation that is affecting both cineSync 4 & 5's ShotGrid integration. We are working to resolve this as soon as possible but in the meantime for any immediate reviews, we suggest sending media through an alternate transfer method (FTP, Aspera etc) so that cineSync reviews can happen.

We will post more info here as soon as we can
Posted May 11, 2022 - 20:29 CEST
Identified
We have identified an issue in the latest update of ShotGrid that appears to be causing issues with the integration. We are working with the appropriate teams to expedite a fix as soon as possible
Posted May 11, 2022 - 20:09 CEST
Investigating
We have received multiple reports of issues with the cineSync and ShotGrid integrations. We are currently investigating and will post an update here as soon as we have more information.
Posted May 11, 2022 - 19:23 CEST
This incident affected: ftrack Services and Components (cineSync).