Video encoding issues

Incident Report for ftrack

Resolved

Issues with video transcoding have been resolved. If you are still seeing any issues with transcoding and asset previews, please reach out to support.
Posted Oct 21, 2025 - 07:53 CEST

Update

All workspaces have been updated with a fix that resolves transcoding issues for all newly submitted jobs. Jobs that are still stuck in "In progress" might still not be resolved.
Posted Oct 20, 2025 - 18:44 CEST

Monitoring

A fix to transcoding issue is being rolled out to all customers affected. This will impact all new transcoding jobs. Existing jobs that are stuck in "In progress" state are still affected by the issue. We will update on the status of these in the next hour.
Posted Oct 20, 2025 - 16:15 CEST

Identified

The issue has been identified and a fix is on the way
Posted Oct 20, 2025 - 15:45 CEST

Investigating

We are investigating an issue with our 3rd party provider for video transcoding in ftrack. Affected regions are EU, US, ASIA
Posted Oct 20, 2025 - 15:38 CEST
This incident affected: ftrack Services and Components (Media hosting & encoding).