Billing and subscription management
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted Aug 22, 2018 - 21:43 CEST
Investigating
We are currently experiencing issues with our billing and subscription management services and signup page. We are investigating and working to resolve the issue as quickly as possible.
Posted Aug 22, 2018 - 16:02 CEST
This incident affected: ftrack Services and Components (Account page).