Connection to Workspaces

Incident Report for ftrack

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 22:57 CEST

Investigating

We’re investigating a partial outage impacting workspace functionality. Updates to follow.
Posted Jun 10, 2025 - 21:55 CEST