Payment provider API issues.
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted May 11, 2021 - 13:42 CEST
Identified
We are currently seeing issues with our payment provider. This may result in errors when signing up or re-configuring your billing settings.

We are working together with our provider to address the issue.
Posted May 10, 2021 - 14:32 CEST
This incident affected: ftrack Services and Components (Account page).