We are continuing to verify the maintenance items.
Posted Jan 20, 2026 - 17:12 CET
Verifying
Verification is currently underway for the maintenance items.
Posted Jan 20, 2026 - 17:11 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 16:58 CET
Scheduled
We will be performing an urgent maintenance on one of the databases in EU region to keep systems operational and improve performance issues for certain customers. During the time, you might see connectivity issues.
Posted Jan 20, 2026 - 16:58 CET
This scheduled maintenance affected: ftrack Services and Components (Hosted applications).