New signups
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 18:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2021 - 14:14 CEST
Investigating
We are currently experiencing issues with new signups. We are currently working with our third party provider to resolve the issue.
Posted Sep 22, 2021 - 13:01 CEST
This incident affected: Hosted applications and Account page.