Downgraded performance for some EU customers

Incident Report for ftrack

Resolved

This incident has been resolved.
Posted May 21, 2025 - 12:24 CEST

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 21:01 CEST

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 15:37 CEST

Update

We are scheduling an urgent database maintenance for 21. May 2025 at 5am CEST which is necessary to stabilise performance of one of our EU clusters. During this time, some customers in EU region will not be able to reach their workspaces. Expected dowtime is 10 minutes. We apologise for this inconvenience.
Posted May 20, 2025 - 15:36 CEST

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 15:30 CEST

Monitoring

The issue seems to be resolved. Impacted services should be performing at regular levels. Please reach out if you are experiencing any similar issues with your workspace. The team will keep monitoring the affected components.
Posted May 20, 2025 - 12:14 CEST

Investigating

We are investigating issue downgrading performance in EU workspaces.
Posted May 20, 2025 - 11:41 CEST
This incident affected: ftrack Services and Components (Hosted applications).