Issue with signup for new trial
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted Aug 02, 2023 - 13:26 CEST
Identified
The issue has been identified and new sign ups are being processed. We will contact users that have have signed up previously but not received their workspace details.
Posted Aug 02, 2023 - 11:01 CEST
Investigating
We're investigating the issue where users are experiencing problems while signing up for new workspaces.
Posted Aug 02, 2023 - 10:20 CEST