EU Hosted Services Experiencing Slowdowns
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 08:24 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 05, 2023 - 08:24 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2023 - 16:27 CEST
Investigating
We want to inform you that our hosted services in the European Union (EU) are experiencing some slowdowns. Our technical team is actively investigating the issue to identify the root cause and implement the necessary measures to restore normal operation.

We understand the impact this may have on your business, and we sincerely apologize for any inconvenience caused. Rest assured, we are prioritizing this and working diligently to minimize the disruption to your operations.
Posted May 23, 2023 - 15:42 CEST
This incident affected: ftrack Services and Components (Hosted applications).