Delayed Email Delivery
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted 11 months ago. Apr 11, 2017 - 04:35 CEST
Investigating
One of our service providers are reporting delays in email processing. We're investigating and working to resolve the issue as quickly as possible.
Posted 11 months ago. Apr 10, 2017 - 22:14 CEST