Sign up and account management unavailable
Incident Report for ftrack
Resolved
The connectivity issues has now been resolved. Should you experience any more issues accessing account management, please reach out to us at support@ftrack.com.
Posted May 04, 2016 - 09:44 CEST
Identified
We are currently experiencing connectivity issues for sign up and account pages.

We are working with our payment service provider to resolve the situation.
Posted May 04, 2016 - 09:15 CEST