Billing and subscription management
Incident Report for ftrack
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 16, 2017 - 14:39 CET
Monitoring
The issue appears to have been resolved by our service provider. We will continue to monitor the status to ensure there are no more disruptions. Should you experience any more issues accessing account management, please reach out to us at support@ftrack.com.
Posted 6 months ago. Mar 16, 2017 - 11:26 CET
Identified
We have identified issues with one of our service providers. We are working with them to resolve the issue affecting our Billing and subscription management services and Signup page.
Posted 6 months ago. Mar 16, 2017 - 09:29 CET
Investigating
We are currently experiencing issues with our Billing and subscription management services and Signup page. We are investigating and working to resolve the issue as quickly as possible.
Posted 6 months ago. Mar 16, 2017 - 09:20 CET